
Installing the Eclipse IDE for C/C++ 

 

These instructions show how to install the Eclipse Integrated Development Environment and set 

it up for C/C++.  The screen shots are from Windows 7.  Plan on many hours to install and setup  

Eclipse with the CDT.  I have installed Eclipse and the CDT numerous times and I always find it 

a pain in the neck.  This time took five hours from beginning to end, including the installation of 

the JDK and MinGW.  You will end with a compiled and executing program. 

 

My instructions will include directions for setting up Eclipse for C/C++.  The C/C++ part of 

Eclipse requires you have installed MinGW (Minimum GNU for Windows).  It smart to install 

MinGW first, but we will do it later so you can see that even with Cygwin installed on your 

computer, the Eclipse CDT (C/C++ Development Tool) will not work without MinGW.  I have 

Cygwin installed on my computer.  It is possible to make Eclipse work with Cygwin, but the 

CDT really wants MinGW, as you will see. 

 

The Eclipse IDE does expect a Java virtual machine to be present on your machine because 

Eclipse needs Java to run.  Eclipse was written in Java.  You could get by with just a JRE, a Java 

runtime environment.  But if you ever do development in Java, even just to learn Java, then you 

need the JDK, Java Development Kit.  Read here:  http://wiki.eclipse.org/Eclipse/Installation.  

With the JDK you can read the documentation on the Java classes.  It is important to have the 

JDK to learn Java. 

 

We are installing Eclipse 3.7.2 and webpage mentioned above tells you that you should install 

Java 6.  The latest Java is Java 7.  Use the above webpage to install Java 6 JDK, the Java 

Development Kit.  Do it now.   

 

I am not providing detailed directions to install the Java JDK because this document is already 

very long.  

Installing the Eclipse IDE 
 

Go to the download website 

 

To discover the latest release of Eclipse, go to Wikipedia.  Every year there is a major release of 

Eclipse, traditionally at June. 

http://en.wikipedia.org/wiki/Eclipse_IDE 

 

Then you need to go to the Eclipse download website 

http://www.eclipse.org/downloads/ 

 

At this time, June 2012, the latest version is 3.7.2, called Indigo.  The next version, Juno, is in 

early release. 

 

http://wiki.eclipse.org/Eclipse/Installation
http://en.wikipedia.org/wiki/Eclipse_IDE
http://www.eclipse.org/downloads/


You need to know your machine.  If you have a 32-bit Windows computer, 

pick that download file and you will get eclipse-SDK-3.7.2-win32.zip, but if it is a 64 bit 

machine you will download eclipse-SDK-3.7.2-win32-x86_64.zip 

 

Before you download it, you should decide where to put it.  For this, you need to understand 

what this zip file will do.  When it is unzipped it will create a directory named “eclipse” within 

whatever directory the zip file is placed.  Then all the Eclipse files will be placed within that 

newly created directory.  You do not need to create a new directory for Eclipse.  You need to 

decide what directory structure you want to end up with.  Two choices are (1) put it directly 

under the C drive root directory and (2) put it under C:\Program Files\.  In this example the code 

is installed directly under the C:\ root directory. 

 

Use Windows explorer to maneuver to the root directory on your main drive, traditionally the C 

drive and put the zip file there. 

C:\ eclipse-SDK-3.7.2-win32-x86_64.zip 

Right click on 

eclipse-SDK-3.7-win32.zip or eclipse-SDK-3.7.2-win32-x86_64.zip  

and select “Extract All” and follow the directions.  If the extract fails, the file might be 

damaged.  I have had this happen.  I went to a different mirror site,  

 

This is what you get when you select Extract All. Notice it suggests that it create a subdirectory 

named  

C:\ eclipse-SDK-3.7.2-win32-x86_64\eclipse\ 

and that it extract everything into that directory.  

 



 
 

 

 

When you say finish it will open the newly created eclipse directory, which will look like the 

following picture. 

 



Open the eclipse folder and it looks like this: 

 
 

 

Create a shortcut to the eclipse.exe with the icon of a purple globe and drag the shortcut to your 

desktop.  You can adjust the name of the shortcut on your desktop by right-clicking on the 

shortcut icon, selecting Properties, and going to the “General” tab to modify the text displayed 

by the icon.  Double-click on it and you will get the following window, “Workspace Launcher.”  



 
 

 I changed the path name to the one show in the following image.  You will want to differentiate 

between C++ and Java projects.  You want all Eclipse workspaces together, so start each name 

with “eclipse.” 

You will learn more about workspaces later. 

 
 

 

After selecting the pathname and hitting “OK”, you will get the following welcome screen. 

 



 
 

 

In the gray-bar area, on the far right you see the word “Workbench” and an icon for a curved 

arrow.  Click on this to get to the workbench, which looks like the following figure. 



 
 

 

At the top right you will see the word “Java” in what looks like a highlighted button, which is 

what it is.   You can code in Java.  You can code in C or C++ but you  must make additions to 

Eclipse to code in C/C++. 

 

Our next step is to add a button next to it that will say “C/C++” so you can select either Java or 

C/C++, but first let us recommend some fine tutorials on using Eclipse with Java. 

 

Eclipse Tutorials 
 

There is a series of free video tutorials by Mark Dexter on the Eclipse IDE available from Source 

Forge on the internet at this URL: 

http://eclipsetutorial.sourceforge.net/ 

 

Even if you are familiar with Eclipse, the tutorial named, “Using the Eclipse Workbench,” is 

worth watching.  You will probably see something new in this video. 

 

The other tutorials are: 

Eclipse and Java for Total Beginners 

http://eclipsetutorial.sourceforge.net/


Eclipse and Java: Introducing Persistence 

Eclipse and Java: Using the Debugger 

 

Each tutorial consists of 6 to 12 lessons, each approximately 15 minutes long.  If you follow 

along with your own Eclipse IDE, you will probably pause the video to catch up with your 

typing, stretching the time to complete each lesson.  Each tutorial shows some new tricks with 

Eclipse. 

 

Remember you are free to download Eclipse and these tutorials at home.  The tutorials use 

Eclipse 3.3, but the newer versions of Eclipse are fine.  The tutorials assume you are using JDK 

1.6.  If you set up Eclipse at home, remember to use JDK 1.6 instead of JRE 6 for your default 

“Installed JRE” in the Window > Preferences > Java > Installed JREs menu.  You need the JDK 

to get the Java source code and Javadoc references used in some lessons.   

 

Adding C/C++ to the Eclipse IDE 
 

To setup Eclipse for C/C++ development you must install the CDT (C/C++ Development Tool). 

You start in the Eclipse workbench by clicking on Help > Install New Software. 

 
Where you see “type or select a site”, click on the drop-arrow to the right and select: 

You must select a software site to use.   

Indigo - http://download.eclipse.org/releases/indigo 

Select this site and after a long wait the window gets populated so it looked like this: 



 
 

 

I expanded Programming Languages line and selected the following 



 
 

 

 



I selected almost everything that said C++.  Visual C++ is a Microsoft tool, which I am not using 

presently so I skipped it.  I clicked on Next and the installation failed with these errors 

 
 

 

Looking closely I see some of the selections say “linuxtools” on the right hand side of the 

window.  I am running Windows, not Linux, so I de-select everything that says “linuxtools” and 

try again. 



 
 

 

That seems successful.  Here is the next screen: 



 
  

You are asked to accept the license agreement. 



 
 

I make a copy of the license and save it in a text file.  I just highlight all the text, copy and paste 

into a Notepad text file. 



 
 

 It takes a few minutes for the software to install   You will be prompted to restart Eclipse, and 

when you do it looks like this: 



 
 

 

 

Now you see it mentions C/C++ Development.  We were successful.  Click on that icon and you 

will get help.  Click instead on the Workbench icon, top right, and you will be back to the 

workbench.  It looks the same as before.  Now click on the small icon that looks like a window 

with a “+” sign on it, just to the left of the highlighted Java button, and you get a menu. Select 

“Other” and you get this window. 



 
 

 

 

Click on “C/C++” then OK and you get the workbench in the C/C++ perspective.  There is now a 

C/C++ button to the left of the Java button and the C/C++ button is highlighted. 

 



 

 

Now the Eclipse IDE will work for either C/C++ or Java, but you must select the “perspective” 

you want by clicking on the appropriate button. 

 

At the very bottom right of the window you will see five icons.  There is a curved arrow that 

goes right-to-left.  Hover over it and it says, “Restore Welcome,” which is the very first page you 

saw.  The other icons are a globe (Overview), something that looks like a chart (Tutorials), 

something that looks like 3 dice of different colors (Samples), and a 4-pointed star (What’s 

New),  all of which appear on the Welcome page. 

 

You can right C/C++ code now, but you cannot compile it until you configure the Eclipse tool to 

see the compiler. 

 

Configuring Eclipse to Compile C/C++ code. 

 

http://max.berger.name/howto/cdt/ar01s04.jsp 

 

 

Here we create a Hello World project.  You select File > New > Project > C++ 

 

http://max.berger.name/howto/cdt/ar01s04.jsp


 
 

After we click on Finish we see we have problems: 



 
 

Close Eclipse.  You need to install MinGW.  I Googled MinGW and downloaded the installer.  I 

selected C, C++ compilers, and the MSys Basic system and the MinGW Development toolkit: 



 
 Click Next: 

 
Then “Install”.  A Windows command window opens: 



 
You get to watch the packages get installed.  The one at the bottom of the screen shot is at 48%.  

It is package after package being installed.  Go read a magazine for a while.  

 

When the installer is finished open Eclipse again.  Delete the HelloWorld project.  Create it again 

with File > New > C++ Project.  Select the “Hello World” project and enter the name 

HelloWorld.  The tool will tell you a project with that name exists already.  You must go to your 

workspace folder and manually delete the HelloWorld folder.  Then you can try again to create a 

HelloWorld project.  Notice the tool now shows “MinGW GCC” in the Toolchains box on the 

right. 



 
 

You can go back to the previous screen shot and see that no toolchain was named.  Click on 

“Finish” and you go back to the workbench.  Do not be alarmed that it still shows errors.  Give it 

a moment and it will resolve the errors you had last time and you will get a project with no 

errors: 



 
 

You click on Run and the program will not run.  So click on Project > Build All and you will see 

that there is now a HelloWorld.exe in a Debug folder on the left side of the workbench: 



 
 

Maneuver with a command window to the executable and run it: 

 
It will fail with this error message: 

 



 
 

The missing file is in C:\MinGW\bin\  You need to add this to the PATH environmental variable. 

In Windows 7 you click on the Windows start button, right-click on “Computer” and select 

Properties. 

 
Click on “Advanced system settings” 

 



 
 

Click on “Environment Variables” 



 
 

Select “Path” and “Edit” and at the end you add  

; C:\MinGW\bin 

Remember to use the “right-arrow” to move to the end of the high-lighted text, otherwise you 

will wipe out the high-lighted text.  Remember to put the semi-colon in front of the entry you are 

making. 

 
 

It is odd, but if you try the executable immediately in the same command window you used 

before, it will not work. 

 

But close the command window, then exit Eclipse and open it again.  Click on the Console tab at 

the bottom right.  Expand the HelloWorld project so you can see HelloWorld.exe under the 

Debug folder.   Right click on it and select Run As > Local C/C++ application.  Now the code 

executes. 



 
 

You can see “Hello World!!!” printed to the Console window. 

 

You now have a free, functioning environment for writing and compiling C and C++ code.  Of 

course, you can also use Eclipse for coding in Java. 


